Security vulnerabilities have been discovered in three popular WordPress plugins: Duplicator, Formidable Forms and Yoast SEO.
The details of the vulnerabilities are as follows:
Duplicator 1.2.28 and older vulnerable to stored XSS
WPVulnDB also reports that the Duplicator, running on over 1 million active sites, fixed a stored cross site scripting vulnerability affecting versions 1.2.28 and older. This report also included the code changes.
Duplicator version 1.2.29 fixed this issue, but their changelog does not mention a vulnerability (there is no currently entry at all for version 1.2.29).
Formidable Forms 2.05.02 and older has multiple severe vulnerabilities
Jouko Pynnönen disclosed multiple vulnerabilities in Formidable Forms version 2.05.02 and older. The report included multiple serious problems:
- A preview function allowed unauthenticated users to execute an arbitrary shortcode. Normally, the use of shortcodes is restricted to site authors or administrators, as many of them could be used to exploit a site.
- One of the plugin’s shortcodes included a SQL injection vulnerability.
- Another shortcode allowed an unauthenticated user to view form responses.
- Form previews were vulnerable to reflected cross site scripting.
- Form input was not sufficiently sanitized to prevent stored cross site scripting, which could have been used to target administrators when they viewed form responses.
All the users of these WordPress Plugin need to update to latest version and they can also use the security plugin Wordfence to protect against these vulnerabilities.
We encourage you to share these vulnerabilities with the larger WordPress community to help keep site owners safe from exploitation.
Did you enjoy this post? Share it!